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SC101 Storage Central: Attach Partition Fails with Error Drive attachment failed

SC101 Storage Central: Attach Partition Fails with Error "Drive attachment failed"

Symptom

While using the SC101 SCM utility to attach a new partition, the error "Drive attachment failed" displays in the Status line (as shown).

Cause

The SC101 partition information is corrupted. This can happen if:

  1. You disconnect a hard drive while the SC101 is powered on.
  2. You move a hard drive from one SC101 to another SC101.
  3. The hard disk has a hardware failure.

Solution

Use a CLI command to fix the corrupted characters. (If "CLI" is unclear to you, read What is a Command Line Interface?)

Examine this screenshot inside a CLI window. The last row in response to a ut_full getpart command shows the numbers that can become corrupted. Here, in the middle of the row, are the correct numbers: 02 00 02 or 01 00 01.

If a mirrored drive is broken, in place of 02 00 02, the numbers are 02 00 01 (shown).

If a non-mirrored drive is broken, the numbers are 01 00 01 (shown).

To Fix this Problem

This involves using a special SC101 command called ut_full. NOTE: This is the only situation NETGEAR recommends using this utility. Do not use it to change attributes of partitions that are working correctly. This might destroy data!

  1. Download the file below to the SC101 directory (If you installed to the default location, C:\Program Files\NETGEAR\SC101 Manager Utility\)
  2. 37.3 KB

  3. Unzip the file. The ut_full.exe file appears in the directory.
  4. Type Start > Run, and type cmd in the pop-up window. Click OK to open a CLI window.
  5. Type cd program files\netgear\sc101* (The last character is a star.) This changes the CLI to the directory where you placed the ut_full.exe file.
  6. Type ut_full listall in the CLI window to view the value for ROOT IP ADDR and the IP ADDR of the partition that failed. Your window will have different values, but in this example the first value is 192.168.50.3 and the second follows the name of this user's broken partition "mirror100", which is 192.168.50.9

  7. Type ut_full getpart, followed by the two IP addresses you found above. If you have protected the parition with a password, include it after the IP addresses (as shown). The attributes of the drive are displayed.
  8. Type ut_full newattr, then the same IP and password information you typed in the last step.
  9. Type these characters carefully:
    • If you have a mirrored drive, type
    • 00 00 00 00 00 00 00 00 02 00 02 00 00 00 0A 07

    • If you do not have a mirrored drive, type

      00 00 00 00 00 00 00 00 01 00 01 00 00 00 0A 07

  10. If you do not see a message "new field set successfully", then power off the SC101, power it on again, and repeat the process from Step 1.

  11. Close the CLI window by typing exit.
  12. Now, return to what you were doing before seeing the error. (Probably, using the SCM utility. In the SCM, select a partition, and click Attach Drive.) If you bring up the SCM, the partition now shows normally.


n101605.asp March 3, 2006

 
   


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